I will update your server PHP to fix the critical php2shell rce


About this gig
PHP2Shell (CVE-2026-109618 & CVE-2026-109619) is a critical remote code execution flaw in PHP itself. Attackers dont need to log in. Fixed PHP versions were released on Oct 21, 2026, and Ill get your server onto one safely.
What I do:
- Check your PHP version(s) and whether youre affected
- Update PHP to a patched release (8.5.12 / 8.4.27 / 8.3.36 / 8.2.35) on 1 server
- Update PHP-FPM, Apache (mod_php) or LiteSpeed config and restart services
- Test that your site and key pages still work after the update
- Check for signs of compromise (unknown or recently changed PHP files)
- Send you a short report of what was done
What I need from you:
- SSH access to your VPS, dedicated or cloud server (temporary access is fine)
- A recent backup or snapshot
Good to know:
- On shared hosting, your host applies the patch. Message me and Ill help you check it.
- PHP 8.1 or older gets no fix. I can upgrade you to a supported version (extra).
Not sure if youre affected? Message me first.
Respect third-party rights
Please be aware that it is against Fiverr's policies for sellers to include themes, templates, or any other elements that infringe third-party rights or applicable laws in the delivered work. Read more about in our Guide to Responsible Digital Creation.
Get to know Arpit
Cloud Engineer AWS : Azure Certified Cloud Professional
- FromIndia
- Member sinceApr 2024
- Avg. response time1 hour
- Last delivery6 months
Languages
Hindi, English
My Portfolio
FAQ
Is my site hacked already?
I check for common signs of compromise, but I can’t prove a clean server. Deeper forensics is a separate extra.
Will there be downtime?
Usually a few seconds to a couple of minutes during the service restart.
Can’t you just give me a script?
Updating PHP on a live server can break extensions, so I test it properly.

