I will patch php2shell, update your PHP version and fix PHP errors


About this gig
the right package.Is your website running on PHP? Patch it against PHP2Shell today.
PHP2Shell (CVE-2026-109618 and CVE-2026-109619) is a critical PHP bug that lets attackers run code on your server without logging in. It affects PHP 5.4 up to PHP 8, and attackers are already exploiting it. The fix is to update PHP to a patched release (8.2.35, 8.3.36, 8.4.27, 8.5.12 or newer).
I will safely update your PHP version and make sure your website keeps working after the update.
What I do:
- Check your current PHP version and if your site is affected
- Take a full backup before any change
- Update PHP to the latest patched version (cPanel, VPS or dedicated server)
- Fix errors, warnings and deprecated code after the upgrade
- Test your pages, forms, login and checkout
- Share a short report of what I changed
Works with:
- Custom PHP, Laravel, CodeIgniter and core PHP websites
- WordPress, WooCommerce and other PHP CMS
- Shared hosting (cPanel / Plesk) and Linux VPS
Why me?
- Basic package delivered in 24 hours
- Backup first, no changes without your approval
- Clear communication from start to finish
Please message me before ordering with your hosting type and current PHP version.
Respect third-party rights
Please be aware that it is against Fiverr's policies for sellers to include themes, templates, or any other elements that infringe third-party rights or applicable laws in the delivered work. Read more about in our Guide to Responsible Digital Creation.
Get to know Emran Hossain
Android App and Web Developer, Java, Kotlin, PHP
- FromBangladesh
- Member sinceJan 2017
- Avg. response time1 hour
- Last delivery8 months
Languages
English
My Portfolio
FAQ
How do I know if my website is affected by PHP2Shell?
If your site runs on PHP 5.4 to 8.x and has not been updated to 8.2.35, 8.3.36, 8.4.27, 8.5.12 or newer, it is most likely affected. Send me your PHP version and I will confirm for free.
Will updating PHP break my website?
It can if the code is old. That is why I take a full backup first, then fix any errors or deprecated code after the update and test your key pages before I deliver.
What access do you need?
Hosting panel (cPanel/Plesk) or SSH access to your server, shared securely through Fiverr. You can change the passwords after the job is done.
My hosting still uses PHP 7.4 or older. Can you help?
Yes. Old PHP versions get no official release, so the best fix is upgrading to a supported PHP 8 version and fixing the code to work with it. The Standard or Premium package covers this.
