I will update PHP to fix php2shell critical rce vulnerability on your website


About this gig
URGENT: Critical PHP2Shell Vulnerability Patch (CVE-2026-109618 / CVE-2026-109619)
On Oct 21, 2026, PHP released emergency patches for two CRITICAL RCE flaws ("PHP2Shell") affecting ALL PHP 5.4 to 8.5.
Even with clean Laravel code, your site is at risk: the bug lives in PHP itself, not your app.
WHAT I WILL DO FOR YOU:
Check current PHP version
Update PHP to patched 8.5.12 / 8.4.27 / 8.3.36 / 8.2.35
Apply temporary mitigation if update not possible yet:
session.upload_progress.enabled = Off
Upgrade projects on PHP 8.1 or older (EOL, no patches)
Scan for compromise signs (malware, logs, web shells)
Verify Laravel compatibility with new PHP
Detailed report of all changes
️ IMPORTANT:
- PHP 8.1 or older gets NO fix (EOL). You MUST upgrade to 8.2+.
- On shared hosting, I'll help confirm your provider applied the patch.
- For websites you OWN or have permission to manage.
PLEASE MESSAGE ME BEFORE ORDERING:
1. Your current PHP version
2. Laravel version
3. Hosting type (VPS, shared, managed, Docker)
4. Any suspicious activity
Don't wait PHP2Shell is already being exploited in the wild!
Respect third-party rights
Please be aware that it is against Fiverr's policies for sellers to include themes, templates, or any other elements that infringe third-party rights or applicable laws in the delivered work. Read more about in our Guide to Responsible Digital Creation.
Get to know Nabil Marouan
Full Stack Developer
- FromMorocco
- Member sinceAug 2023
- Last delivery1 year
Languages
English, Arabic, French
FAQ
What is PHP2Shell?
PHP2Shell is the nickname for two critical vulnerabilities (CVE-2026-109618 and CVE-2026-109619) disclosed on October 21, 2026. They allow attackers to execute arbitrary code on vulnerable PHP servers remotely, without authentication.
Is my Laravel website affected?
Yes — if your server runs any PHP version between 5.4 and 8.5 (unpatched), you're vulnerable. The bug is in PHP itself, not in your Laravel code, so even perfectly written applications are at risk.
What PHP versions are fixed?
The patched versions are: PHP 8.5.12, 8.4.27, 8.3.36, and 8.2.35. PHP 8.1 and older are End-of-Life and will NOT receive fixes — you must upgrade.
What if I can't update PHP immediately?
As a temporary mitigation, you can disable session upload progress by setting session.upload_progress.enabled = Off in your php.ini file. This reduces but doesn't eliminate the risk.
I'm on shared hosting. What should I do?
Contact your hosting provider immediately and ask if they have applied the PHP2Shell patches. I can help you draft a professional support ticket and verify if the patch was actually applied.
How do I know if my site has been hacked?
I will check for suspicious files, analyze access logs for exploit attempts, review running processes, and scan for known web shells. In the Premium package, I include a full malware scan.
